This version of Nextcloud is not compatible with PHP 7.1.
You are currently running 7.2.34-28+0~20211119.67+debian10~1.gbpf24e81.